summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMGislv2021-09-19 13:55:24 +0200
committerMGislv2021-09-19 13:55:24 +0200
commit8246b6d7f1f62f755cb8feb28d44cd2bb429dd56 (patch)
treec2b597899f68f6d1ccd757636adb6feba0422806
parent12e74449cb5fc00b65ebf2764fbbb7394e98727d (diff)
downloadaur-8246b6d7f1f62f755cb8feb28d44cd2bb429dd56.tar.gz
fix updates
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64f7a5284eda..c5c7770db119 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vim-clipboard
pkgdesc = Vi Improved, a highly configurable, improved version of the vi text editor
pkgver = 8.2.3441
- pkgrel = 1
+ pkgrel = 2
url = https://www.vim.org
arch = x86_64
license = custom:vim
@@ -17,7 +17,7 @@ pkgbase = vim-clipboard
makedepends = tcl
makedepends = pcre
makedepends = zlib
- depends = vim-runtime=8.2.3441-1
+ depends = vim-runtime
depends = gpm
depends = acl
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index 5e65ed5015b3..a2c13efa7ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
pkgname=vim-clipboard
pkgver=8.2.3441
-pkgrel=1
+pkgrel=2
pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
url='https://www.vim.org'
arch=('x86_64')
license=('custom:vim')
-depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'acl' 'glibc' 'libxt' 'libgcrypt' 'zlib')
+depends=('vim-runtime' 'gpm' 'acl' 'glibc' 'libxt' 'libgcrypt' 'zlib')
makedepends=('glibc' 'libgcrypt' 'gpm' 'python2' 'python' 'ruby' 'libxt' 'lua'
'gawk' 'tcl' 'pcre' 'zlib')
optdepends=('python2: Python 2 language support'
@@ -28,7 +28,16 @@ source=(https://github.com/vim/vim/archive/v${pkgver}/vim-${pkgver}.tar.gz)
sha256sums=('3db6c3af32b741c2e618358bbf002cffe9db2ab8d21f9ea277110fce54fec4d2')
sha512sums=('1d85fdb2d6b50f0b786a8436d091a084b9ca0bb43c3cfbdeaa329b231b82ea790589b7bae6bdb6e60b2c12c97cc4178ab8e61677e0c1070c805021cfdbc34d5f')
+_vimrun_ver=$(pacman -Q vim-runtime | awk '{print $2}')
+
prepare() {
+ if [ "${_vimrun_ver%-*}" = "$pkgver" ]; then
+ echo "OK, vim-runtime ver matches $pkgver"
+ else
+ echo "ERROR, please update vim-runtime"
+ exit
+ fi
+
cd vim-${pkgver}/src
# define the place for the global (g)vimrc file (set to /etc/vimrc)
sed -E 's|^.*(#define SYS_.*VIMRC_FILE.*").*$|\1|g' -i feature.h