summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 07:03:34 +0800
committerSainnhepark2020-07-28 07:03:34 +0800
commitb87b8acd738106accfce33a6472873747f3113f7 (patch)
treeb01cb708df7fcaffb813c9a4b25d531d81b2d885
parent858af184ad8d807dc793e5d278301bee34a7ee7c (diff)
downloadaur-b87b8acd738106accfce33a6472873747f3113f7.tar.gz
add post_install hook
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--vim-coc.install7
3 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97a9aa8445af..c2c05f1e75b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,19 +3,21 @@ pkgbase = vim-coc
pkgver = 0.0.78
pkgrel = 4
url = https://github.com/neoclide/coc.nvim
+ install = vim-coc.install
arch = any
license = MIT
depends = vim
depends = nodejs
optdepends = npm: for installing coc extensions
optdepends = yarn: for installing coc extensions
- optdepends = vim-coc-extras-git: additional necessary extensions
provides = vim-coc
conflicts = vim-coc
source = https://github.com/neoclide/coc.nvim/archive/v0.0.78.tar.gz
source = coc-vim-doc.hook
+ source = vim-coc.install
sha256sums = 1e9634b9c5de3557d8ecf3057fcaa1958d70a8d433eec2da19d88f8d486c2695
sha256sums = 71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d
+ sha256sums = 6ae0d6ea2bb700e8f1e9b00e7c770d9a9e5b0e2c18dc9ba50e9d45cd17d08f6d
pkgname = vim-coc
diff --git a/PKGBUILD b/PKGBUILD
index 43a301387896..8a36f3a417fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,16 @@ url='https://github.com/neoclide/coc.nvim'
license=('MIT')
depends=('vim' 'nodejs')
optdepends=('npm: for installing coc extensions'
- 'yarn: for installing coc extensions'
- 'vim-coc-extras-git: additional necessary extensions')
+ 'yarn: for installing coc extensions')
+install=vim-coc.install
provides=('vim-coc')
conflicts=('vim-coc')
source=('https://github.com/neoclide/coc.nvim/archive/v0.0.78.tar.gz'
- 'coc-vim-doc.hook')
+ 'coc-vim-doc.hook'
+ 'vim-coc.install')
sha256sums=('1e9634b9c5de3557d8ecf3057fcaa1958d70a8d433eec2da19d88f8d486c2695'
- '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d')
+ '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d'
+ '6ae0d6ea2bb700e8f1e9b00e7c770d9a9e5b0e2c18dc9ba50e9d45cd17d08f6d')
build() {
cd "${srcdir}/coc.nvim-${pkgver}"
diff --git a/vim-coc.install b/vim-coc.install
new file mode 100644
index 000000000000..c62e9ec93610
--- /dev/null
+++ b/vim-coc.install
@@ -0,0 +1,7 @@
+post_install() {
+ BLUE='\033[0;34m'
+ BGREEN='\033[1;32m'
+ NC='\033[0m' # No Color
+
+ printf "\n${BLUE}Install the ${BGREEN}vim-coc-extras-git${BLUE} package group to get some important extensions.${NC}\n\n"
+}