summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2021-03-26 18:59:56 +0800
committerSainnhe Park2021-03-26 18:59:56 +0800
commitdda2b971a7914c4e32a76b5a7ec4792e488408aa (patch)
tree3b6e68e127c3e09f206e54c46f874858ff413dbf
parentfc29d7c9c022e7533393f7d2717d219dd5c50598 (diff)
downloadaur-dda2b971a7914c4e32a76b5a7ec4792e488408aa.tar.gz
Compile from master branch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8beacbeecebe..236eae6b5530 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = vim-coc
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
pkgver = 0.0.80
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
+ makedepends = yarn
depends = vim
depends = nodejs
optdepends = npm: for installing coc extensions
optdepends = yarn: for installing coc extensions
optdepends = watchman: for workspace_didChangeWatchedFiles feature
- optdepends = vim-coc-extras-meta: some basic extensions
provides = vim-coc
conflicts = vim-coc
- source = https://github.com/neoclide/coc.nvim/archive/v0.0.80.tar.gz
- sha256sums = 6bc817a8fcb42ed4ce139bb128a0087520be1c73d197968b163e9125c9a80ba6
+ source = https://github.com/neoclide/coc.nvim/archive/c90a07eec847d38909702454c9e096ac6d392aff.zip
+ sha256sums = 3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2
pkgname = vim-coc
diff --git a/PKGBUILD b/PKGBUILD
index dad69e0da43f..4f161f36e253 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=vim-coc
+# Coc.nvim creates tags on release branch but the source code is only available on master branch, so I have to use commit hash to specify the version to use.
+_hash='c90a07eec847d38909702454c9e096ac6d392aff'
pkgver=0.0.80
-pkgrel=2
+pkgrel=3
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -9,18 +11,24 @@ license=('MIT')
depends=('vim' 'nodejs')
optdepends=('npm: for installing coc extensions'
'yarn: for installing coc extensions'
- 'watchman: for workspace_didChangeWatchedFiles feature'
- 'vim-coc-extras-meta: some basic extensions')
+ 'watchman: for workspace_didChangeWatchedFiles feature')
+makedepends=('yarn')
provides=('vim-coc')
conflicts=('vim-coc')
-source=("https://github.com/neoclide/coc.nvim/archive/v${pkgver}.tar.gz")
-sha256sums=('6bc817a8fcb42ed4ce139bb128a0087520be1c73d197968b163e9125c9a80ba6')
+source=("https://github.com/neoclide/coc.nvim/archive/${_hash}.zip")
+sha256sums=('3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2')
+
+build() {
+ cd "${srcdir}/coc.nvim-${_hash}"
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache"
+ yarn run build
+}
package() {
- cd "${srcdir}/coc.nvim-${pkgver}"
+ cd "${srcdir}/coc.nvim-${_hash}"
vim -es --cmd ":helptags doc" --cmd ":q"
- find autoload bin build data doc package.json plugin -type f -exec \
+ find autoload build data doc package.json plugin -type f -exec \
install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/pack/coc/start/coc.nvim/{}" \;
- install -Dm 644 "${srcdir}/coc.nvim-${pkgver}/LICENSE.md" \
+ install -Dm 644 "${srcdir}/coc.nvim-${_hash}/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}