summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-29 10:47:33 +0800
committerSainnhepark2020-07-29 10:47:33 +0800
commit56ee31933736f895663164a526d64081fa21d8a4 (patch)
tree1c835dcda200f079c258b6244ed5fca1a9d86fa1
downloadaur-56ee31933736f895663164a526d64081fa21d8a4.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef7b99da077b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-coc-clangd-git
+ pkgdesc = clangd extension for coc.nvim
+ pkgver = r102.fd082e5
+ pkgrel = 1
+ url = https://github.com/clangd/coc-clangd
+ arch = any
+ license =
+ makedepends = yarn
+ makedepends = npm
+ depends = vim-coc
+ depends = git
+ depends = clang
+ provides = vim-coc-clangd
+ conflicts = vim-coc-clangd
+ source = coc-clangd::git+https://github.com/clangd/coc-clangd.git
+ sha256sums = SKIP
+
+pkgname = vim-coc-clangd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96022e38bff2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+_variant='vim'
+_extname=coc-clangd
+_packdir="usr/share/vim/vimfiles/pack/coc/start/${_extname}"
+url='https://github.com/clangd/coc-clangd'
+pkgdesc='clangd extension for coc.nvim'
+
+pkgname="${_variant}-${_extname}-git"
+provides=("${_variant}-${_extname}")
+conflicts=("${_variant}-${_extname}")
+arch=('any')
+depends=("${_variant}-coc" 'git' 'clang')
+makedepends=('yarn' 'npm')
+license=('')
+source=("${_extname}::git+${url}.git")
+pkgver=r102.fd082e5
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+ yarn pack
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production --no-lockfile --ignore-scripts
+}
+
+package() {
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
+}