summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 12:14:40 +0800
committerSainnhepark2020-10-23 12:14:40 +0800
commit9d34860429d4c7fe746ca09db8c2b4ca081a216e (patch)
tree5204f31649e6dec3b9bc67781632252031f0f41b
parent1ecc751625c2561372f12e8b76e8b45afbb1a939 (diff)
downloadaur-9d34860429d4c7fe746ca09db8c2b4ca081a216e.tar.gz
add license
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63db5c815a77..76f832014612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = vim-coc-clangd-git
pkgdesc = C/C++/ObjC support for coc.nvim (powered by clangd)
- pkgver = r102.fd082e5
+ pkgver = r116.a3650f2
pkgrel = 1
url = https://github.com/clangd/coc-clangd
arch = any
- license =
+ license = Apache
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index c7d718aa86b4..a6a7eb92d6c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc" 'clang')
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('Apache')
source=("${_extname}::git+${url}.git")
-pkgver=r102.fd082e5
+pkgver=r116.a3650f2
pkgrel=1
sha256sums=('SKIP')
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}