summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 09:26:11 +0800
committerSainnhepark2020-07-28 09:26:11 +0800
commit4feaf393a0dc30b27252269c0c8720080a9940a7 (patch)
treec5033accbce76d1a241f38218e64dc6c1a034012
parentb8d53338b1aa844c2c3522dec30e4fa3818be77f (diff)
downloadaur-4feaf393a0dc30b27252269c0c8720080a9940a7.tar.gz
put meta-package in optdepends
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--vim-coc-git.install7
3 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c34fc30c618c..b3f0adfb123c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,6 @@ pkgbase = vim-coc-git
pkgver = v0.0.78.r106.g140321e6
pkgrel = 2
url = https://github.com/neoclide/coc.nvim
- install = vim-coc-git.install
arch = any
license = MIT
makedepends = git
@@ -11,14 +10,13 @@ pkgbase = vim-coc-git
depends = nodejs
optdepends = npm: for installing coc extensions
optdepends = yarn: for installing coc extensions
+ optdepends = vim-coc-extras-meta-git: some basic extensions
provides = vim-coc
conflicts = vim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
source = coc-vim-doc.hook
- source = vim-coc-git.install
sha256sums = SKIP
sha256sums = 71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d
- sha256sums = b7e8a3870c82b4ac59c553b9e6414d85e59b706545416bfc47a17eb1e35e205d
pkgname = vim-coc-git
diff --git a/PKGBUILD b/PKGBUILD
index 96a3608a8384..2851b70d3ff6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,15 @@ url='https://github.com/neoclide/coc.nvim'
license=('MIT')
depends=('vim' 'nodejs')
optdepends=('npm: for installing coc extensions'
- 'yarn: for installing coc extensions')
-install=vim-coc-git.install
+ 'yarn: for installing coc extensions'
+ 'vim-coc-extras-meta-git: some basic extensions')
makedepends=('git')
provides=('vim-coc')
conflicts=('vim-coc')
source=('git+https://github.com/neoclide/coc.nvim.git#branch=release'
- 'coc-vim-doc.hook'
- 'vim-coc-git.install')
+ 'coc-vim-doc.hook')
sha256sums=('SKIP'
- '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d'
- 'b7e8a3870c82b4ac59c553b9e6414d85e59b706545416bfc47a17eb1e35e205d')
+ '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d')
pkgver() {
cd "${srcdir}/coc.nvim"
diff --git a/vim-coc-git.install b/vim-coc-git.install
deleted file mode 100644
index 53697417db75..000000000000
--- a/vim-coc-git.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- BLUE='\033[0;34m'
- BGREEN='\033[1;32m'
- NC='\033[0m' # No Color
-
- printf "\n${BLUE}Install the ${BGREEN}vim-coc-extras-meta-git${BLUE} meta-package to get some important extensions.${NC}\n\n"
-}