summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-27 10:05:29 +0800
committerSainnhepark2020-07-27 10:05:29 +0800
commit77b4ec0260f1a526cf1c2f205e7432af28337bed (patch)
tree853af06335fdb0faaaa7ee5065debfc99e47480d
parent9924e228f9f2f4663e74b3344d7276e4e122742b (diff)
downloadaur-77b4ec0260f1a526cf1c2f205e7432af28337bed.tar.gz
add hook to generate helptags
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--coc-vim-doc.hook11
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6ccfcd01ca0..26293bf87e91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vim-coc-git
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
pkgver = v0.0.78.r106.g140321e6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
@@ -13,7 +13,9 @@ pkgbase = vim-coc-git
provides = vim-coc
conflicts = vim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
+ source = coc-vim-doc.hook
sha256sums = SKIP
+ sha256sums = 71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d
pkgname = vim-coc-git
diff --git a/PKGBUILD b/PKGBUILD
index d6cd255a0103..e8bba809b68a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=vim-coc-git
pkgver=v0.0.78.r106.g140321e6
-pkgrel=1
+pkgrel=2
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -11,18 +11,26 @@ optdepends=('npm: for installing coc extensions' 'yarn: for installing coc exten
makedepends=('git')
provides=('vim-coc')
conflicts=('vim-coc')
-source=('git+https://github.com/neoclide/coc.nvim.git#branch=release')
-sha256sums=('SKIP')
+source=('git+https://github.com/neoclide/coc.nvim.git#branch=release'
+ 'coc-vim-doc.hook')
+sha256sums=('SKIP'
+ '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d')
pkgver() {
cd "${srcdir}/coc.nvim"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "${srcdir}/coc.nvim"
+ touch doc/tags doc/tags-cn
+}
+
package() {
cd "${srcdir}/coc.nvim"
find autoload bin build data doc package.json plugin -type f -exec \
install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/pack/coc/start/coc.nvim/{}" \;
install -Dm 644 "${srcdir}/coc.nvim/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm 644 "${srcdir}"/coc-vim-doc.hook "${pkgdir}"/usr/share/libalpm/hooks/coc-vim-doc.hook
}
diff --git a/coc-vim-doc.hook b/coc-vim-doc.hook
new file mode 100644
index 000000000000..e1617d48f5d4
--- /dev/null
+++ b/coc-vim-doc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/vim/vimfiles/pack/coc/start/coc.nvim/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/pack/coc/start/coc.nvim/doc" --cmd ":q"
+When = PostTransaction