summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-26 13:16:53 +0800
committerSainnhepark2020-07-26 13:16:53 +0800
commit9b3d02052a5d5c4709e4eb8554600fa267ef6947 (patch)
tree06c805582b930ee7dff3df4a116ec86fbfa4b6f2
parentbc43c6b519fde2585afdafe6b2712cd1ebc03c08 (diff)
downloadaur-9b3d02052a5d5c4709e4eb8554600fa267ef6947.tar.gz
add optdepends
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD1
2 files changed, 3 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 410e99e01792..4b076b986853 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = vim-coc-git
makedepends = git
depends = vim
depends = nodejs
+ optdepends = npm: for installing coc extensions
+ optdepends = yarn: for installing coc extensions
provides = vim-coc
conflicts = vim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
diff --git a/PKGBUILD b/PKGBUILD
index 86aad9ff542c..5dcdfcd5adac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,6 +6,7 @@ arch=('any')
url='https://github.com/neoclide/coc.nvim'
license=('MIT')
depends=('vim' 'nodejs')
+optdepends=('npm: for installing coc extensions' 'yarn: for installing coc extensions')
makedepends=('git')
provides=('vim-coc')
conflicts=('vim-coc')