summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 07:09:04 +0800
committerSainnhepark2020-07-28 07:09:04 +0800
commita8634d915df9e8724508734d35ee2593b668647e (patch)
treeea421b3b1ae4d95b6fa8b531160e04bc6b983908
parent77b4ec0260f1a526cf1c2f205e7432af28337bed (diff)
downloadaur-a8634d915df9e8724508734d35ee2593b668647e.tar.gz
add post_install hook
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
-rw-r--r--vim-coc-git.install7
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26293bf87e91..723f32aa6b13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = vim-coc-git
pkgver = v0.0.78.r106.g140321e6
pkgrel = 2
url = https://github.com/neoclide/coc.nvim
+ install = vim-coc-git.install
arch = any
license = MIT
makedepends = git
@@ -14,8 +15,10 @@ pkgbase = vim-coc-git
conflicts = vim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
source = coc-vim-doc.hook
+ source = vim-coc-git.install
sha256sums = SKIP
sha256sums = 71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d
+ sha256sums = 6ae0d6ea2bb700e8f1e9b00e7c770d9a9e5b0e2c18dc9ba50e9d45cd17d08f6d
pkgname = vim-coc-git
diff --git a/PKGBUILD b/PKGBUILD
index e8bba809b68a..99baaa21541a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,18 @@ arch=('any')
url='https://github.com/neoclide/coc.nvim'
license=('MIT')
depends=('vim' 'nodejs')
-optdepends=('npm: for installing coc extensions' 'yarn: for installing coc extensions')
+optdepends=('npm: for installing coc extensions'
+ 'yarn: for installing coc extensions')
+install=vim-coc-git.install
makedepends=('git')
provides=('vim-coc')
conflicts=('vim-coc')
source=('git+https://github.com/neoclide/coc.nvim.git#branch=release'
- 'coc-vim-doc.hook')
+ 'coc-vim-doc.hook'
+ 'vim-coc-git.install')
sha256sums=('SKIP'
- '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d')
+ '71348fe1287df827e7b28c41a0659e0cc8ff541623c3e1cc8fbfc84346199b1d'
+ '6ae0d6ea2bb700e8f1e9b00e7c770d9a9e5b0e2c18dc9ba50e9d45cd17d08f6d')
pkgver() {
cd "${srcdir}/coc.nvim"
diff --git a/vim-coc-git.install b/vim-coc-git.install
new file mode 100644
index 000000000000..c62e9ec93610
--- /dev/null
+++ b/vim-coc-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ BLUE='\033[0;34m'
+ BGREEN='\033[1;32m'
+ NC='\033[0m' # No Color
+
+ printf "\n${BLUE}Install the ${BGREEN}vim-coc-extras-git${BLUE} package group to get some important extensions.${NC}\n\n"
+}