summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:30:37 +0800
committerSainnhepark2020-10-23 16:30:37 +0800
commit51d9f09f2905f7c170a5d0bfbcffa465e3134e4d (patch)
tree74f1e0de43cfef721c424a5e6182ec8e53cd959b
parent3063e1a6d3e72a35528377b45706b87ce02fd510 (diff)
downloadaur-51d9f09f2905f7c170a5d0bfbcffa465e3134e4d.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d919c71c9fd8..3cb924f2db0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = vim-coc-highlight-git
url = https://github.com/neoclide/coc-highlight
arch = any
groups = vim-coc-extras-git
- license =
+ license = MIT
makedepends = git
makedepends = yarn
makedepends = npm
diff --git a/PKGBUILD b/PKGBUILD
index 0df26afef37c..9a92733240b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-highlight'
depends=('vim-coc')
makedepends=('git' 'yarn' 'npm')
_packdir="usr/share/vim/vimfiles/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('vim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}