summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-27 17:57:02 +0800
committerSainnhepark2020-07-27 17:57:02 +0800
commit76b9e6d91ebcfff8b448b0a5aadc250ccdcc42b5 (patch)
treeade5b6d8a80e810aa9eb8081f0eeef0b0fa60a3c
downloadaur-76b9e6d91ebcfff8b448b0a5aadc250ccdcc42b5.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5368e22a4e80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-coc-highlight-git
+ pkgdesc = Document highlight and document colors LSP support for coc.nvim
+ pkgver = 1.2.5.r2.gb4e82eb
+ pkgrel = 1
+ url = https://github.com/neoclide/coc-highlight
+ arch = any
+ groups = vim-coc-extras
+ license =
+ makedepends = git
+ makedepends = yarn
+ makedepends = npm
+ depends = vim-coc
+ provides = vim-coc-highlight
+ conflicts = vim-coc-highlight
+ source = coc-highlight::git+https://github.com/neoclide/coc-highlight.git
+ sha256sums = SKIP
+
+pkgname = vim-coc-highlight-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb33bfbdb613
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=vim-coc-highlight-git
+_pkgname=vim-coc-highlight
+_extname=coc-highlight
+pkgdesc='Document highlight and document colors LSP support for coc.nvim'
+arch=('any')
+url='https://github.com/neoclide/coc-highlight'
+depends=('vim-coc')
+makedepends=('git' 'yarn' 'npm')
+_packdir="usr/share/vim/vimfiles/pack/coc/start/${_extname}"
+license=('')
+groups=('vim-coc-extras')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_extname}::git+${url}.git")
+pkgver=1.2.5.r2.gb4e82eb
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ find lib package.json -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}