summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:38:19 +0800
committerSainnhepark2020-10-23 16:38:19 +0800
commitcba03707893a5ae476ed4459f474194d63936057 (patch)
tree836c1dfd479707080db2581f9c1424702086e235
parent44b3c5b05bcdef6b77b2cef4077c6e2baceeb9e1 (diff)
downloadaur-cba03707893a5ae476ed4459f474194d63936057.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4e1128afcf8..e5810f114216 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = vim-coc-json-git
pkgrel = 1
url = https://github.com/neoclide/coc-json
arch = any
- license =
+ license = MIT
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 3e67f3111b86..4fa09680434c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('MIT')
source=("${_extname}::git+${url}.git")
pkgver=1.2.6.r0.g66b482d
pkgrel=1
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}