summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-27 17:58:42 +0800
committerSainnhepark2020-07-27 17:58:42 +0800
commitafd4b4a185c66b7b82bb085dd5261ba46eb5c580 (patch)
tree2fdbbcdc79c6a61ec9a50e744037a7aea54f1798
downloadaur-afd4b4a185c66b7b82bb085dd5261ba46eb5c580.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e834d567e6ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-coc-lists-git
+ pkgdesc = Common lists for coc.nvim
+ pkgver = 1.3.10.r0.gbf352d6
+ pkgrel = 1
+ url = https://github.com/neoclide/coc-lists
+ arch = any
+ groups = vim-coc-extras
+ license =
+ makedepends = git
+ makedepends = yarn
+ makedepends = npm
+ depends = vim-coc
+ provides = vim-coc-lists
+ conflicts = vim-coc-lists
+ source = coc-lists::git+https://github.com/neoclide/coc-lists.git
+ sha256sums = SKIP
+
+pkgname = vim-coc-lists-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1559b1c20d18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=vim-coc-lists-git
+_pkgname=vim-coc-lists
+_extname=coc-lists
+pkgdesc='Common lists for coc.nvim'
+arch=('any')
+url='https://github.com/neoclide/coc-lists'
+depends=('vim-coc')
+makedepends=('git' 'yarn' 'npm')
+_packdir="usr/share/vim/vimfiles/pack/coc/start/${_extname}"
+license=('')
+groups=('vim-coc-extras')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_extname}::git+${url}.git")
+pkgver=1.3.10.r0.gbf352d6
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ find lib nvimstart package.json -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}