summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:58:02 +0800
committerSainnhepark2020-07-28 16:58:02 +0800
commitb9db934eb67a78dff3be05beb3d19ad62da620eb (patch)
tree8e24d2fe89bbdbbf7a5778dd5f52157beea0fa13
parent43d37ac98715d82c115945eb6615d41b5d5cd9d1 (diff)
downloadaur-b9db934eb67a78dff3be05beb3d19ad62da620eb.tar.gz
update build()
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50f6c03f4574..00419eb22922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js nvimstart package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}