summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:45:29 +0800
committerSainnhepark2020-10-23 16:45:29 +0800
commit0f2505514778bac426756ab5867961d1de91debe (patch)
tree0293881ab9554bdf0a1e02bf1c16b9d9091c6d9d
parent1867cbcbac48e12ce36d75754f0b900453f7ff01 (diff)
downloadaur-0f2505514778bac426756ab5867961d1de91debe.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec14fc64fdea..0fd563138871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = vim-coc-pairs-git
url = https://github.com/neoclide/coc-pairs
arch = any
groups = vim-coc-extras-git
- license =
+ license = MIT
makedepends = git
makedepends = yarn
makedepends = npm
diff --git a/PKGBUILD b/PKGBUILD
index 0854180b1111..8b8a2c1ac0c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-pairs'
depends=('vim-coc')
makedepends=('git' 'yarn' 'npm')
_packdir="usr/share/vim/vimfiles/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('vim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}