summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:21:52 +0800
committerSainnhepark2020-07-28 16:21:52 +0800
commit69b668fbbb1afd183357e24eb785c6a1ee2eda47 (patch)
treea9f28fd438001451ac96c5c47453df66b8fbd046
parentb6314352dd969c9dc3a672d16c135549cf42ca07 (diff)
downloadaur-69b668fbbb1afd183357e24eb785c6a1ee2eda47.tar.gz
update build()
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00d00079203f..cf4b176487ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ yarn install --frozen-lockfile --production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}