summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:53:05 +0800
committerSainnhepark2020-10-23 16:53:05 +0800
commit0ff27cd78d78388af09dd25654d4f5357084c3b6 (patch)
treeadf9a6af053c207c9075c8ad01a1af2e6be5e8b3
parentf41f283341dad835a4c851db5342528349777a7b (diff)
downloadaur-0ff27cd78d78388af09dd25654d4f5357084c3b6.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25b6816c6c81..57f6f7051334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = vim-coc-rust-analyzer-git
pkgrel = 1
url = https://github.com/fannheyward/coc-rust-analyzer
arch = any
- license =
+ license = MIT
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 0d5325789a50..3b9277e2d07d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('MIT')
source=("${_extname}::git+${url}.git")
pkgver=r464.4b3847f
pkgrel=1
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}