summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 17:06:06 +0800
committerSainnhepark2020-10-23 17:06:06 +0800
commit9c89ee50f04be89427b645d4e3805c29227c215b (patch)
tree034eba459384a5839af50615735b9740275004a2
parent2860891d13ed5ba61881baf9df04064633defb8e (diff)
downloadaur-9c89ee50f04be89427b645d4e3805c29227c215b.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e09a7a5c96c..6f92cbf10f8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = vim-coc-vimlsp-git
pkgrel = 1
url = https://github.com/iamcco/coc-vimlsp
arch = any
- license =
+ license = unknown
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index ff0427b12078..c2b279b902ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('unknown')
source=("${_extname}::git+${url}.git")
pkgver=v0.8.0.r6.g0b7001d
pkgrel=1
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}