summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-29 01:03:07 -0500
committerLuis Martinez2021-04-29 01:03:07 -0500
commit80d10d9b9cee079d9e85775709951c76433415a3 (patch)
tree8d7fd62eac968dcb82c1681a62e32b39d24e01ca
downloadaur-80d10d9b9cee079d9e85775709951c76433415a3.tar.gz
initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD59
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c22a3b9861dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = vim-code-dark-git
+ pkgdesc = A dark colorscheme for Vim inspired by Dark+ in VSCode
+ pkgver = r105.670fed5
+ pkgrel = 1
+ url = https://github.com/tomasiser/vim-code-dark
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-code-dark-git::git+https://github.com/tomasiser/vim-code-dark
+ sha256sums = SKIP
+
+pkgname = vim-code-dark-git
+ depends = vim-plugin-runtime
+ optdepends = vim-airline-code-dark
+ optdepends = vim-lightline-code-dark
+ provides = vim-code-dark
+ conflicts = vim-code-dark
+
+pkgname = vim-airline-code-dark-git
+ depends = vim-plugin-runtime
+ depends = vim-airline
+ optdepends = vim-code-dark
+ provides = vim-airline-code-dark
+ conflicts = vim-airline-code-dark
+
+pkgname = vim-lightline-code-dark-git
+ depends = vim-plugin-runtime
+ depends = vim-lightline-git
+ optdepends = vim-code-dark
+ provides = vim-lightline-code-dark
+ conflicts = vim-lightline-code-dark
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ad5fe70c1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgbase=vim-code-dark-git
+pkgname=('vim-code-dark-git'
+ 'vim-airline-code-dark-git'
+ 'vim-lightline-code-dark-git')
+pkgver=r105.670fed5
+pkgrel=1
+pkgdesc="A dark colorscheme for Vim inspired by Dark+ in VSCode"
+arch=('any')
+url="https://github.com/tomasiser/vim-code-dark"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgbase::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_vim-code-dark-git() {
+ depends=('vim-plugin-runtime')
+ optdepends=('vim-airline-code-dark'
+ 'vim-lightline-code-dark')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dvm 644 colors/codedark.vim -t "$pkgdir/usr/share/vim/vimfiles/colors/"
+ install -Dvm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_vim-airline-code-dark-git() {
+ depends=('vim-plugin-runtime' 'vim-airline')
+ optdepends=('vim-code-dark')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dvm 644 {,"$pkgdir/usr/share/vim/vimfiles/"}autoload/airline/themes/codedark.vim
+ install -Dvm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_vim-lightline-code-dark-git() {
+ depends=('vim-plugin-runtime' 'vim-lightline-git')
+ optdepends=('vim-code-dark')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dvm 644 {,"$pkgdir/usr/share/vim/vimfiles/"}autoload/lightline/colorscheme/codedark.vim
+ install -Dvm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}