summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x472016-10-25 14:29:42 +0200
committer0x472016-10-25 14:33:28 +0200
commit51110d5066047169a5763fc0a301163a78626b63 (patch)
tree2fcbece9ed46c7649bc2772ef43c092cb1437882
downloadaur-51110d5066047169a5763fc0a301163a78626b63.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9db3237c881
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-colorscheme-unsuck-flat-git
+ pkgdesc = A Vim / GVim color scheme that tries not to suck as hard as the existing ones
+ pkgver = 1.be38bc4
+ pkgrel = 1
+ url = https://github.com/unsuckvim/unsuck-flat
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = vim
+ conflicts = vim-colorscheme-unsuck-flat
+ source = git+https://github.com/unsuckvim/unsuck-flat.git
+ sha256sums = SKIP
+
+pkgname = vim-colorscheme-unsuck-flat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d003bab82b9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: 0x47
+
+pkgname=vim-colorscheme-unsuck-flat-git
+_instname=vim-colorscheme-unsuck-flat
+_gitname=unsuck-flat
+pkgver=1.be38bc4
+pkgver() {
+ cd "$_gitname" || exit
+ echo "$(git rev-list --count master).$(git rev-parse --short master)"
+}
+pkgrel=1
+pkgdesc="A Vim / GVim color scheme that tries not to suck as hard as the existing ones"
+
+arch=('any')
+url='https://github.com/unsuckvim/unsuck-flat'
+license=('GPL3')
+depends=('vim')
+conflicts=($_instname)
+makedepends=('git')
+source=('git+https://github.com/unsuckvim/unsuck-flat.git')
+sha256sums=('SKIP')
+
+package() {
+ install_dir="$pkgdir/usr/share/vim/vimfiles/colors"
+ install -dm755 $install_dir
+ install -Dm644 "$srcdir/$_gitname/unsuck-flat.vim" $install_dir/
+}
+