summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-08-11 17:02:42 +1000
committerRhinoceros2015-08-11 17:02:42 +1000
commitc5f399ec5b38e3ad6023df4a64b0e73cf3f25d79 (patch)
treedc2a74f924bef5b2d0952135c99546238714ce0b
downloadaur-c5f399ec5b38e3ad6023df4a64b0e73cf3f25d79.tar.gz
Initial commit of 20140831-1
* Originally submitted by Andy Weidenbaum <archbaum@gmail.com>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--vimdoc.install19
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98bf86b9f9d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-committia-git
+ pkgdesc = A Vim plugin for more pleasant editing of Git commit messages
+ pkgver = 20140831
+ pkgrel = 1
+ url = https://github.com/rhysd/committia.vim
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-committia
+ conflicts = vim-committia
+ source = vim-committia::git+https://github.com/rhysd/committia.vim
+ sha256sums = SKIP
+
+pkgname = vim-committia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4789ce6d4db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=vim-committia-git
+pkgver=20140831
+pkgrel=1
+pkgdesc="A Vim plugin for more pleasant editing of Git commit messages"
+arch=('any')
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+url="https://github.com/rhysd/committia.vim"
+license=('MIT')
+source=(${pkgname%-git}::git+https://github.com/rhysd/committia.vim)
+sha256sums=('SKIP')
+provides=('vim-committia')
+conflicts=('vim-committia')
+install=vimdoc.install
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/vim-committia/README.md"
+
+ msg 'Installing appdirs...'
+ install -dm 755 "$pkgdir/usr/share/vim/vimfiles"
+ for _appdir in autoload plugin; do
+ cp -dpr --no-preserve=ownership $_appdir "$pkgdir/usr/share/vim/vimfiles/$_appdir"
+ done
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..220693cc8af7
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*