summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2017-12-26 17:19:47 -0800
committerFabio Zanini2017-12-26 17:19:47 -0800
commite04e1a5eb10f413460478e029b3162b73d350670 (patch)
tree8be35bfbd34a249a6c31987ee568d82065e6bf4b
downloadaur-vim-completor-git.tar.gz
Initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--vimdoc.install16
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df7c39afabb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-completor-git
+ pkgdesc = Asynchronous code completion framework for vim8
+ pkgver = r227.6e4fba0
+ pkgrel = 1
+ url = https://github.com/maralla/completor.vim
+ install = vimdoc.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = vim-runtime
+ source = vim-completor-git::git+https://github.com/maralla/completor.vim.git#branch=master
+ md5sums = SKIP
+
+pkgname = vim-completor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05dcd3852f3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: fabio zanini <fabio dot zanini at fastmail dot fm>
+pkgname=vim-completor-git
+pkgver=r227.6e4fba0
+pkgrel=1
+pkgdesc='Asynchronous code completion framework for vim8'
+arch=('any')
+url='https://github.com/maralla/completor.vim'
+license=('MIT')
+depends=('vim-runtime')
+makedepends=('git')
+install='vimdoc.install'
+source=("vim-completor-git::git+https://github.com/maralla/completor.vim.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ _installpath="$pkgdir/usr/share/vim/vimfiles/pack/completor/start/completor.vim"
+ install -d "$_installpath"
+ cp -r ./* "$_installpath/"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..4ec1842171fb
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: