summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-11 19:35:49 -0500
committerlmartinez-mirror2021-04-11 19:35:49 -0500
commitff1244f466f7e1b55ee9d1ca0624188bd61c9e28 (patch)
tree83f1120aaebb756223382c3ed61a20021832b299
parent6aa93e0cca7764cfcd1addf68c4b9800f846595d (diff)
downloadaur-ff1244f466f7e1b55ee9d1ca0624188bd61c9e28.tar.gz
rewrite and fixed upstream URL
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76c515bd316d..98cfdef776eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Mon Jan 18 14:55:58 UTC 2016
pkgbase = vim-cpp-enhanced-highlight-git
- pkgdesc = Additional Vim syntax highlighting for C++ (including C++11/14)
+ pkgdesc = Additional Vim syntax highlighting for C++
pkgver = r45.a8024aa
pkgrel = 1
- url = https://github.com/octol-lang/vim-cpp-enhanced-highlight
+ url = https://github.com/octol/vim-cpp-enhanced-highlight
arch = any
- license = None
+ license = unknown
makedepends = git
- source = git://github.com/octol/vim-cpp-enhanced-highlight.git
+ depends = vim-plugin-runtime
+ source = vim-cpp-enhanced-highlight-git::git+https://github.com/octol/vim-cpp-enhanced-highlight
sha256sums = SKIP
pkgname = vim-cpp-enhanced-highlight-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
index 07c66fc12494..d4bc8b4ce1cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Jeremy Ruten <jeremy.ruten@gmail.com>
+# Maintainer: lmartinez-mirror
+# Contributor: Jeremy Ruten <jeremy.ruten@gmail.com>
pkgname=vim-cpp-enhanced-highlight-git
-pkgver=r45.a8024aa
+pkgver=0.1.r93.g27e0ffc
pkgrel=1
-pkgdesc="Additional Vim syntax highlighting for C++ (including C++11/14)"
+pkgdesc="Additional Vim syntax highlighting for C++"
arch=('any')
-url="https://github.com/octol-lang/vim-cpp-enhanced-highlight"
-license=('None')
+url="https://github.com/octol/vim-cpp-enhanced-highlight"
+license=('unknown')
+depends=('vim-plugin-runtime')
makedepends=('git')
-source=('git://github.com/octol/vim-cpp-enhanced-highlight.git')
+source=("$pkgname::git+$url")
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/vim-cpp-enhanced-highlight
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
}
package() {
- cd $srcdir/vim-cpp-enhanced-highlight
- local vimfiles="${pkgdir}/usr/share/vim/vimfiles"
- install -D -m644 after/syntax/c.vim "${vimfiles}/after/syntax/c.vim"
- install -D -m644 after/syntax/cpp.vim "${vimfiles}/after/syntax/cpp.vim"
+ cd "$pkgname"
+ find after \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}