summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-16 23:54:49 -0500
committerLuis Martinez2021-10-16 23:54:49 -0500
commit149c928dfd1f74d69028e2f7e5b37614e37613f1 (patch)
tree3041b08b43b7638845fd69d52e4db8410a261ef3
downloadaur-149c928dfd1f74d69028e2f7e5b37614e37613f1.tar.gz
initial commit based on vim-dadbod
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af65bc00ff02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-dadbod-git
+ pkgdesc = Modern database interface for Vim
+ pkgver = 1.4.r3.g8fcde4c
+ pkgrel = 1
+ url = https://github.com/tpope/vim-dadbod
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-dadbod-git::git+https://github.com/tpope/vim-dadbod
+ md5sums = SKIP
+
+pkgname = vim-dadbod-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38dd34ea497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=vim-dadbod-git
+pkgver=1.4.r3.g8fcde4c
+pkgrel=1
+pkgdesc="Modern database interface for Vim"
+arch=('any')
+url="https://github.com/tpope/vim-dadbod"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 README.markdown "$pkgdir/usr/share/doc/$pkgname/README.md"
+}