summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-07-20 23:15:11 +0200
committerChristian Rebischke2016-07-20 23:15:11 +0200
commitb12a10a611ce5f28cc4dec869526fdbe6b43cbe9 (patch)
tree74cdf3b1962f375ad86d5a321ad8c42d9e440a51
downloadaur-b12a10a611ce5f28cc4dec869526fdbe6b43cbe9.tar.gz
first push
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--vimdoc.install20
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d243468e561d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jul 20 20:43:27 UTC 2016
+pkgbase = vim-devicons
+ pkgdesc = Adds file type glyphs/icons to many popular Vim plugins such as: NERDTree, vim-airline, unite, vim-startify and many more
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/ryanoasis/vim-devicons
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim
+ source = https://github.com/ryanoasis/vim-devicons/archive/v0.8.3.tar.gz
+ sha512sums = 17ad617ee918eb5a865749a62a4955783bbf72191946112fac7cdde141372689a726f94e805f62f74285f623e97cb0d677fb86cb4c5beca27fc4483175cf7295
+
+pkgname = vim-devicons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f54716b698c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+pkgname=vim-devicons
+pkgver=0.8.3
+pkgrel=1
+pkgdesc='Adds file type glyphs/icons to many popular Vim plugins such as: NERDTree, vim-airline, unite, vim-startify and many more'
+arch=('any')
+url='https://github.com/ryanoasis/vim-devicons'
+license=('MIT')
+depends=('vim')
+groups=('vim-plugins')
+install="vimdoc.install"
+source=("https://github.com/ryanoasis/vim-devicons/archive/v${pkgver}.tar.gz")
+sha512sums=('0295304c02bad3455de52b475ec232d7252e81e83b664f6e5a3a2b516a9a99c7e8b628ed8fb3c9268ba8ac82a8f00060b4a43b58a99593593accdf4b9094bc1e')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles/"{plugin,doc,autoload/vimfiler/columns,pythonx/vim_devicons,nerdtree_plugin,autoload/airline/extensions/tabline/formatters}
+ find . -type d -exec chmod 755 '{}' \;
+ cp plugin/* "$pkgdir/usr/share/vim/vimfiles/plugin/"
+ cp nerdtree_plugin/webdevicons.vim "${pkgdir}/usr/share/vim/vimfiles/nerdtree_plugin/webdevicons.vim"
+ install -Dm0644 doc/webdevicons.txt "${pkgdir}/usr/share/vim/vimfiles/doc/webdevicons.txt"
+ cp autoload/airline/extensions/tabline/formatters/webdevicons.vim "$pkgdir/usr/share/vim/vimfiles/autoload/airline/extensions/tabline/formatters/webdevicons.vim"
+ cp autoload/vimfiler/columns/devicons.vim "$pkgdir/usr/share/vim/vimfiles/autoload/vimfiler/columns/devicons.vim"
+ cp -dr pythonx/* "${pkgdir}/usr/share/vim/vimfiles/pythonx/"
+}
+
+# vim:set et sw=2 ts=2 tw=79:
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..1239c9df3be5
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*
+