summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Albanese2015-06-20 19:00:58 +0200
committerFrancesco Albanese2015-06-20 19:00:58 +0200
commit2603eabccf143ce418d8aff667659f10535943ad (patch)
tree10293ed983beb713005c06e74893d3ce3aaabf48
downloadaur-2603eabccf143ce418d8aff667659f10535943ad.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..866b8ac64294
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-easytags
+ pkgdesc = Automatically create a global tags file with ctags and keep it up-to-date as you edit files in Vim.
+ pkgver = 3.10.1
+ pkgrel = 1
+ url = https://github.com/xolox/vim-easytags
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim
+ depends = ctags
+ depends = vim-misc-xolox
+ depends = python
+ source = vim-easytags-3.10.1.tar.gz::https://github.com/xolox/vim-easytags/tarball/3.10.1
+ sha256sums = 7378f6500543ea546c423666c76fe7ff8b234d9040fcc3ced4aae4f439bb9e11
+
+pkgname = vim-easytags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da2c721717c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Francesco Albanese <frances dot albanese at gmail dot com>
+pkgname=vim-easytags
+pkgver=3.10.1
+pkgrel=1
+pkgdesc="Automatically create a global tags file with ctags and keep it up-to-date as you edit files in Vim."
+arch=(any)
+url="https://github.com/xolox/vim-easytags"
+license=('MIT')
+groups=('vim-plugins')
+depends=("vim" "ctags" "vim-misc-xolox" "python")
+source=($pkgname-$pkgver.tar.gz::https://github.com/xolox/$pkgname/tarball/$pkgver)
+noextract=()
+sha256sums=('7378f6500543ea546c423666c76fe7ff8b234d9040fcc3ced4aae4f439bb9e11')
+
+package() {
+ _gittag=a339a8c
+ cd "$srcdir/xolox-$pkgname-$_gittag"
+ install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
+ tar -c . \
+ --exclude INSTALL.md \
+ --exclude README.md \
+ --exclude TODO.md \
+ --exclude .gitignore \
+ --exclude addon-info.json \
+ | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
+}