summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornrio2015-09-13 15:21:53 +0200
committernrio2015-09-13 15:21:53 +0200
commit99c8dd4853211faa67906925b56139d32acde380 (patch)
tree21ca137eeb80665508c4e3f0876b38e584726616
downloadaur-99c8dd4853211faa67906925b56139d32acde380.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
-rw-r--r--manifest.txt20
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39d83bed78ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-elixir-git
+ pkgdesc = Vim configuration files for Elixir
+ pkgver = r211.f2c747d
+ pkgrel = 1
+ url = https://github.com/elixir-lang/vim-elixir
+ arch = any
+ license = Apache
+ makedepends = git
+ optdepends = vim-matchit: Use % to jump between "do" and "end"
+ source = git+https://github.com/elixir-lang/vim-elixir.git
+ source = manifest.txt
+ sha256sums = SKIP
+ sha256sums = 77928ee91ea696f23888d086a543cfc9a0e6f619fd3b5a3d5f4d017c5f8fa888
+
+pkgname = vim-elixir-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d447be60046
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: nrio <nrio@mailbox.org>
+pkgname=vim-elixir-git
+pkgver=r211.f2c747d
+pkgrel=1
+pkgdesc="Vim configuration files for Elixir"
+arch=('any')
+url="https://github.com/elixir-lang/vim-elixir"
+license=('Apache')
+makedepends=('git')
+optdepends=('vim-matchit: Use % to jump between "do" and "end"')
+source=('git+https://github.com/elixir-lang/vim-elixir.git'
+ 'manifest.txt')
+sha256sums=('SKIP'
+'77928ee91ea696f23888d086a543cfc9a0e6f619fd3b5a3d5f4d017c5f8fa888')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ local vimfiles="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 compiler/exunit.vim "${vimfiles}/compiler/exunit.vim"
+ install -Dm644 ftdetect/elixir.vim "${vimfiles}//ftdetect/elixir.vim"
+ install -Dm644 ftdetect/eelixir.vim "${vimfiles}/ftdetect/eelixir.vim"
+ install -Dm644 ftplugin/elixir.vim "${vimfiles}//ftplugin/elixir.vim"
+ install -Dm644 ftplugin/eelixir.vim "${vimfiles}/ftplugin/eelixir.vim"
+ install -Dm644 indent/elixir.vim "${vimfiles}//indent/elixir.vim"
+ install -Dm644 indent/eelixir.vim "${vimfiles}/indent/eelixir.vim"
+ install -Dm644 syntax/elixir.vim "${vimfiles}//syntax/elixir.vim"
+ install -Dm644 syntax/eelixir.vim "${vimfiles}/syntax/eelixir.vim"
+
+ if ! find . \( -path ./.git -o -path ./spec \) -prune -o -print | sort | cmp -s "${srcdir}/manifest.txt"
+ then
+ msg "WARNING: Some files have been added or removed in the git repository."
+ msg "Package may need updating."
+ fi
+}
diff --git a/manifest.txt b/manifest.txt
new file mode 100644
index 000000000000..ef08352daf60
--- /dev/null
+++ b/manifest.txt
@@ -0,0 +1,20 @@
+.
+./compiler
+./compiler/exunit.vim
+./ftdetect
+./ftdetect/eelixir.vim
+./ftdetect/elixir.vim
+./ftplugin
+./ftplugin/eelixir.vim
+./ftplugin/elixir.vim
+./Gemfile
+./Gemfile.lock
+./indent
+./indent/eelixir.vim
+./indent/elixir.vim
+./LICENSE
+./README.md
+./syntax
+./syntax/eelixir.vim
+./syntax/elixir.vim
+./.travis.yml