summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2015-06-21 18:13:06 +0200
committerrevel2015-06-21 18:13:06 +0200
commit55f9862e95f6907dca01377ed9c5599c0079a981 (patch)
tree54bc3ef6a0b26a232b2b20f3a3ed309f90bed519
downloadaur-55f9862e95f6907dca01377ed9c5599c0079a981.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--vimdoc.install14
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cf36e94fafb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-endwise
+ pkgdesc = Wisely add "end" in ruby, endfunction/endif/more in vim script, etc
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://www.vim.org/scripts/script.php?script_id=2386
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ depends = vim
+ source = vim-endwise.zip::http://www.vim.org/scripts/download_script.php?src_id=21704
+ md5sums = 55130343b89e56d9c52c82921146f338
+ sha256sums = e896e765f6b207e00e7e28850483520816ccf47d5f7b26587be51ad312ececff
+
+pkgname = vim-endwise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be77a7f807ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: revel <revelΘmuub·net>
+
+pkgname=vim-endwise
+pkgver=1.2
+_scriptid=21704
+pkgrel=2
+pkgdesc='Wisely add "end" in ruby, endfunction/endif/more in vim script, etc'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=2386'
+license=('custom:vim')
+depends=('vim')
+groups=('vim-plugins')
+install=vimdoc.install
+source=("${pkgname}.zip"::"http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
+md5sums=('55130343b89e56d9c52c82921146f338')
+sha256sums=('e896e765f6b207e00e7e28850483520816ccf47d5f7b26587be51ad312ececff')
+
+package() {
+ install -Dm644 "plugin/endwise.vim" "$pkgdir/usr/share/vim/vimfiles/plugin/endwise.vim"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..0ffd9dde87b1
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}