summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Dziedzic2013-08-30 02:23:18 +0000
committerEli Schwartz2015-07-08 13:16:06 -0400
commit50bea6f3e5db70b16d232bd5aba90053a997267d (patch)
tree3f1e368bd02fc25390f71ee00fd843e499e5b00b
downloadaur-50bea6f3e5db70b16d232bd5aba90053a997267d.tar.gz
Initial upload: vim-eunuch v1.0.5.g6a4d193-1
Imported old history from aur-mirror: updated on Fri Aug 30 02:23:15 UTC 2013 filter-branch: add .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--vimdoc.install35
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e03d78cd6d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-eunuch
+ pkgdesc = Vim sugar for the UNIX shell commands that need it the most, by tpope
+ pkgver = v1.0.5.g6a4d193
+ pkgrel = 1
+ url = https://github.com/tpope/vim-eunuch
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim
+ provides = vim-eunuch
+ conflicts = vim-eunuch
+ source = git+https://github.com/tpope/vim-eunuch
+ sha256sums = SKIP
+
+pkgname = vim-eunuch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..540bc4a868d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=vim-eunuch
+_gitname='vim-eunuch'
+pkgver=v1.0.5.g6a4d193
+pkgrel=1
+pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
+arch=('any')
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+url="https://github.com/tpope/vim-eunuch"
+license=('custom:vim')
+source=(git+https://github.com/tpope/vim-eunuch)
+sha256sums=('SKIP')
+provides=('vim-eunuch')
+conflicts=('vim-eunuch')
+install=vimdoc.install
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd $_gitname
+
+ msg 'Removing unneeded files...'
+ rm -f README.markdown
+}
+
+package() {
+ cd $_gitname
+
+ msg 'Installing...'
+ install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
+ tar -c . | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..31487f37216a
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,35 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ printf "$eunuch\n"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+read -d '' eunuch <<"EOF"
+# vim-eunuch-git
+
+Vim sugar for the UNIX shell commands that need it the most. Commands include:
+
+:Unlink: Delete a buffer and the file on disk simultaneously.
+:Remove: Like :Unlink, but doesn't require a neckbeard.
+:Move: Rename a buffer and the file on disk simultaneously.
+:Chmod: Change the permissions of the current file.
+:Find: Run find and load the results into the quickfix list.
+:Locate: Run locate and load the results into the quickfix list.
+:SudoWrite: Write a privileged file with sudo.
+:W: Write every open window. Handy for kicking off tools like guard.
+EOF
+
+op=$1
+shift
+
+$op $*