summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2015-07-08 13:28:30 -0400
committerEli Schwartz2015-07-08 13:29:47 -0400
commitfe4c80d1298141b9045c8651f8697447587d7a10 (patch)
tree7a767985f7941d6b238b0c1d1786c3c705c27c93
parent5e993c228141b3fa119a733581736fc92aa65bf6 (diff)
downloadaur-fe4c80d1298141b9045c8651f8697447587d7a10.tar.gz
upgpkg: vim-eunuch 1.1-2
Adopt package, fix everything.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
-rw-r--r--vimdoc.install34
3 files changed, 19 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1444b5f60a1d..8d1d1d8b0d2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = vim-eunuch
pkgdesc = Vim sugar for the UNIX shell commands that need it the most, by tpope
pkgver = 1.1
- pkgrel = 1
- url = http://www.vim.org/scripts/script.php?script_id=4300
+ pkgrel = 2
+ url = https://github.com/tpope/vim-eunuch
install = vimdoc.install
arch = any
groups = vim-plugins
license = custom:vim
depends = vim
- provides = vim-eunuch
- source = vim-eunuch.zip::http://www.vim.org/scripts/download_script.php?src_id=21847
- sha256sums = 687f615c3b7c204f14560d9df75ff20c310a49253152e2d72452682489707c8b
+ source = https://github.com/tpope/vim-eunuch/archive/v1.1.tar.gz
+ sha256sums = e452ddd541ef10e5fa9af48e36b181df6d95e5fe96fcea56cf41b20f99db8532
pkgname = vim-eunuch
diff --git a/PKGBUILD b/PKGBUILD
index b6a1ce02ae10..8bfccf725494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
-# Maintainer: Felip Manyer i Ballester <archlinux at res hyphen telae dot cat>
-# Contributor: Andy Weidenbaum <archbaum at gmail.com>
+# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
pkgname=vim-eunuch
pkgver=1.1
-_srcid=21847
-pkgrel=1
+pkgrel=2
pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
arch=('any')
-depends=('vim')
-groups=('vim-plugins')
-url="http://www.vim.org/scripts/script.php?script_id=4300"
+url="https://github.com/tpope/${pkgname}"
license=('custom:vim')
-source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_srcid})
-sha256sums=('687f615c3b7c204f14560d9df75ff20c310a49253152e2d72452682489707c8b')
-provides=('vim-eunuch')
+groups=('vim-plugins')
+depends=('vim')
install=vimdoc.install
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('e452ddd541ef10e5fa9af48e36b181df6d95e5fe96fcea56cf41b20f99db8532')
package() {
- cd "$srcdir"
-
- rm ${pkgname}.zip
-
- msg 'Installing...'
- install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
- tar -c . | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}/usr/share/vim/vimfiles"
+ find * -maxdepth 0 -type d -exec cp -rt "${pkgdir}/usr/share/vim/vimfiles" '{}' \+
}
diff --git a/vimdoc.install b/vimdoc.install
index 93765785500f..a5f1f9a8c61f 100644
--- a/vimdoc.install
+++ b/vimdoc.install
@@ -1,38 +1,14 @@
post_install() {
- echo -n "Updating vim help tags..."
- /usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo -n "Updating Vim help tags..."
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
echo "done."
- printf "$eunuch\n"
}
post_upgrade() {
- post_install $1
+ post_install
}
post_remove() {
- echo -n "Updating vim help tags..."
- /usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
- echo "done."
+ post_install
}
-
-read -d '' eunuch <<"EOF"
-# vim-eunuch
-
-Vim sugar for the UNIX shell commands that need it the most. Commands include:
-
-:Unlink: Delete a buffer and the file on disk simultaneously.
-:Remove: Like :Unlink, but doesn't require a neckbeard.
-:Move: Rename a buffer and the file on disk simultaneously.
-:Chmod: Change the permissions of the current file.
-:Find: Run find and load the results into the quickfix list.
-:Locate: Run locate and load the results into the quickfix list.
-:SudoWrite: Write a privileged file with sudo.
-:W: Write every open window. Handy for kicking off tools like guard.
-EOF
-
-op=$1
-shift
-
-$op $*