summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2015-08-30 23:30:03 -0400
committeryhfudev2015-08-30 23:30:03 -0400
commit6ebdaf714deb711d6463326696f4c4d1034a6f71 (patch)
treece2da6fc1b6a5cd6f464e3e880559513c4cb47e2
downloadaur-6ebdaf714deb711d6463326696f4c4d1034a6f71.tar.gz
init
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD74
-rw-r--r--vimdoc.install27
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db4f90666ec0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = vim-exvim
+ pkgdesc = exVim make the vim as an IDE like environment all in vimscript.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://exvim.github.io/docs/
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ depends = gvim
+ depends = ctags
+ depends = gawk
+ depends = python
+ depends = python2
+ depends = make
+ depends = cscope
+ depends = graphviz
+ depends = source-highlight
+ depends = idutils
+ provides = vim-a
+ conflicts = vim-a
+ conflicts = vim-cmdline-complete
+ conflicts = vim-enhcomm
+ conflicts = vim-nerdtree
+ conflicts = vim-omnicppcomplete
+ conflicts = vim-genutils
+ conflicts = vim-surround
+ conflicts = vim-visincr
+ conflicts = vim-vimwiki
+ conflicts = vim-echofunc
+ conflicts = vim-cref
+ conflicts = vim-minibufexpl
+ conflicts = vim-lookupfile
+ conflicts = vim-showmarks
+ conflicts = vim-taglist
+ conflicts = vim-visual_studio
+ source = https://github.com/exvim/main/releases/download/v0.5.0/exvim-v0.5.0.tar.gz
+ md5sums = 9590008f87bdd2f8e6669e279cb82c6e
+
+pkgname = vim-exvim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..597c941d8d90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Yunhui Fu <yhfudev@gmail.com>
+# Contributor: Tianjiao Yin <ytj000@gmail.com>
+
+pkgname=vim-exvim
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="exVim make the vim as an IDE like environment all in vimscript. "
+arch=("any")
+url="http://exvim.github.io/docs/"
+license=('unknown')
+groups=('vim-plugins')
+depends=(
+ 'gvim'
+ 'ctags'
+ 'gawk'
+ 'python'
+ 'python2'
+ 'make'
+ 'cscope'
+ 'graphviz'
+ 'source-highlight'
+ 'idutils'
+ )
+
+conflicts=(
+
+#####################################
+# Need not to have any modification #
+#####################################
+
+ 'vim-a'
+ 'vim-cmdline-complete'
+ 'vim-enhcomm'
+ 'vim-nerdtree'
+ 'vim-omnicppcomplete'
+ 'vim-genutils'
+ 'vim-surround'
+ 'vim-visincr'
+ 'vim-vimwiki'
+
+#################################
+# Must be modified to fit exVim #
+#################################
+
+ 'vim-echofunc'
+ 'vim-cref'
+ 'vim-minibufexpl'
+ 'vim-lookupfile'
+ 'vim-showmarks'
+ 'vim-taglist'
+ 'vim-visual_studio'
+ )
+
+provides=${conflicts}
+install=vimdoc.install
+source=(
+ #"${pkgname}-${pkgver}.tar.gz::https://github.com/exvim/main/releases/download/v${pkgver}/exvim-v${pkgver}.tar.gz"
+ "https://github.com/exvim/main/releases/download/v${pkgver}/exvim-v${pkgver}.tar.gz"
+ )
+
+build() {
+ echo "replace your ~/.vimrc:"
+ echo "let g:exvim_custom_path='/usr/share/exvim/'"
+ echo "source /usr/share/exvim/.vimrc"
+}
+
+package() {
+ cd ${srcdir}
+ rm -f "exvim-v${pkgver}.tar.gz"
+ mkdir -p ${pkgdir}/usr/share/exvim
+ cp -r * .vimrc .vimrc.mini .vimrc.plugins ${pkgdir}/usr/share/exvim
+}
+
+md5sums=('9590008f87bdd2f8e6669e279cb82c6e')
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..2e9f56bbc06d
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,27 @@
+post_install() {
+ #echo -n "Updating vim help tags..."
+ #/usr/bin/vim --noplugins -u NONE -U NONE --cmd ":helptags /usr/share/exvim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ echo "let \$EX_DEV='/usr/share/exvim' \" Generated by exVim" >> /etc/vimrc
+ echo "let g:ex_toolkit_path = \$EX_DEV.'/tools' \" Generated by exVim " >> /etc/vimrc
+ echo ""
+ echo "To enable exvim, replace your ~/.vimrc:"
+ echo " let g:exvim_custom_path='/usr/share/exvim/'"
+ echo " source /usr/share/exvim/.vimrc"
+ echo ""
+ echo "To create a new project:"
+ echo " vim project_name.exvim"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*