summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2017-02-20 23:50:51 +0100
committerRobert Kubosz2017-02-20 23:50:51 +0100
commit60a6d7b79282dac91894d7428d2ae08bc4d6d763 (patch)
treece2ea50bd5c9b0badb4a9c3e19f3717ad63a6d8b
downloadaur-60a6d7b79282dac91894d7428d2ae08bc4d6d763.tar.gz
first release of package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--vimdoc.install14
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44b85f8feb21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-fastfold
+ pkgdesc = Vim plugin to speed up syntax foldmethod
+ pkgver = 5.0
+ pkgrel = 1
+ url = https://github.com/Konfekt/FastFold
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ depends = vim
+ source = https://github.com/Konfekt/FastFold/archive/5.0.tar.gz
+ md5sums = 8fa4a566bdfe3cc74595d57603686f57
+
+pkgname = vim-fastfold
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..693c0d3c34b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Robert Kubosz <kuboszrobert at gmail dot com>
+
+pkgname=vim-fastfold
+pkgver=5.0
+pkgrel=1
+pkgdesc='Vim plugin to speed up syntax foldmethod'
+arch=('any')
+url='https://github.com/Konfekt/FastFold'
+groups=('vim-plugins')
+depends=('vim')
+install='vimdoc.install'
+source=("${url}/archive/${pkgver}.tar.gz")
+md5sums=('8fa4a566bdfe3cc74595d57603686f57')
+
+package() {
+ cd "${srcdir}/FastFold-${pkgver}"
+
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -Dm644 doc/FastFold.txt "$installpath/doc/fastfold.txt"
+ install -Dm644 plugin/fastfold.vim "$installpath/plugin/fastfold.vim"
+}
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..33200d6a38d0
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ':helptags /usr/share/vim/vimfiles/doc' --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}