summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2015-06-12 00:13:39 +0800
committeryesuu2015-06-12 00:13:39 +0800
commit34ead689d6402dfc0b278c1dec76b84ffb5cf051 (patch)
tree4657b97fbd2d1e41062dc47e69a19a166694e2bf
downloadaur-34ead689d6402dfc0b278c1dec76b84ffb5cf051.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce1343779cb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-fcitx
+ pkgdesc = Keep and restore fcitx state for each buffer separately when leaving/re-entering insert mode. Like always typing English in normal mode, but Chinese in insert mode.
+ pkgver = 1.2.4
+ pkgrel = 5
+ url = http://www.vim.org/scripts/script.php?script_id=3764
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ depends = vim>=7.0
+ optdepends = fcitx: input support
+ source = http://www.vim.org/scripts/download_script.php?src_id=21006
+ sha256sums = 4b8560082fa9dae2a895ad8fa60a24392f47d12352072ba019f1fb5350fc1b78
+
+pkgname = vim-fcitx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4757c2ad4698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+
+pkgname=vim-fcitx
+pkgver=1.2.4
+pkgrel=5
+pkgdesc="Keep and restore fcitx state for each buffer separately when leaving/re-entering insert mode. Like always typing English in normal mode, but Chinese in insert mode. "
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=3764"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim>=7.0')
+optdepends=('fcitx: input support')
+source=('http://www.vim.org/scripts/download_script.php?src_id=21006')
+sha256sums=('4b8560082fa9dae2a895ad8fa60a24392f47d12352072ba019f1fb5350fc1b78')
+
+package() {
+ cd ${srcdir}
+ install --directory "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r plugin "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r so "${pkgdir}/usr/share/vim/vimfiles"
+}