summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2015-06-26 01:26:03 -0400
committerEli Schwartz2015-06-26 01:26:03 -0400
commit2aca5cd51cbb40e5e82c208b90b9e018fe116160 (patch)
tree22a07188062b0b52f1957cc4a8a17a7defc57739
downloadaur-2aca5cd51cbb40e5e82c208b90b9e018fe116160.tar.gz
Initial upload: vim-flagship-git 1.0.r7.g6fb105f-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--vimdoc.install14
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b21bfea677ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-flagship-git
+ pkgdesc = Configurable and extensible tab line and status line, by tpope
+ pkgver = 1.0.r7.g6fb105f
+ pkgrel = 1
+ url = https://github.com/tpope/vim-flagship
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim
+ provides = vim-flagship
+ conflicts = vim-flagship
+ source = git://github.com/tpope/vim-flagship.git
+ sha512sums = SKIP
+
+pkgname = vim-flagship-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d3fce4e6397
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
+
+pkgname=vim-flagship-git
+pkgver=1.0.r7.g6fb105f
+pkgrel=1
+pkgdesc="Configurable and extensible tab line and status line, by tpope"
+arch=('any')
+url="https://github.com/tpope/${pkgname%-git}"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=vimdoc.install
+source=("git://github.com/tpope/${pkgname%-git}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c2-
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -dm755 "${pkgdir}/usr/share/vim/vimfiles"
+ find * -maxdepth 0 -type d -exec cp -rt "${pkgdir}/usr/share/vim/vimfiles" '{}' \+
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..a5f1f9a8c61f
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating Vim help tags..."
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}