summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMillHaruto2024-12-08 11:15:52 +0800
committerMillHaruto2024-12-08 11:15:52 +0800
commitbec9b1eedccb5ee83cb75d97c1b303c00096a64a (patch)
tree687a1ecf0476b4c3668650f1421b211a5e4b0708
downloadaur-bec9b1eedccb5ee83cb75d97c1b303c00096a64a.tar.gz
init pkg
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a31c11dc6dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-floaterm-git
+ pkgdesc = 💻 Terminal manager for (neo)vim
+ pkgver = r4e28c8d
+ pkgrel = 1
+ url = https://github.com/voldikss/vim-floaterm
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-floaterm-git::git+https://github.com/voldikss/vim-floaterm
+ sha256sums = SKIP
+
+pkgname = vim-floaterm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c392b4238bfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mill Haruto <mill4134[at]outlook[dot]com>
+
+pkgname=vim-floaterm-git
+pkgver=r4e28c8d
+pkgrel=1
+pkgdesc='💻 Terminal manager for (neo)vim'
+arch=('any')
+url='https://github.com/voldikss/vim-floaterm'
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse --short HEAD | sed 's/^/r/'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload bin doc lua plugin -type f \
+ -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}