summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-04 14:58:45 -0500
committerLuis Martinez2021-05-04 14:58:45 -0500
commit48a32a73de72da6c1063e40d9ee5103f6ad35715 (patch)
treea487f0f1e345685e140e25d5d95eeaa87c7ff142
downloadaur-vim-fzf-checkout-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..105cdb2bc280
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-fzf-checkout-git
+ pkgdesc = Vim plugin for managing branches and tags with fzf
+ pkgver = r108.aaab59e
+ pkgrel = 1
+ url = https://github.com/stsewd/fzf-checkout.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ depends = fzf
+ provides = vim-fzf-checkout
+ conflicts = vim-fzf-checkout
+ source = vim-fzf-checkout-git::git+https://github.com/stsewd/fzf-checkout.vim
+ sha256sums = SKIP
+
+pkgname = vim-fzf-checkout-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce51e00f6f0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-fzf-checkout-git
+pkgver=r108.aaab59e
+pkgrel=1
+pkgdesc='Vim plugin for managing branches and tags with fzf'
+arch=('any')
+url="https://github.com/stsewd/fzf-checkout.vim"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime' 'fzf')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}