summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-04 23:45:02 -0600
committerLuis Martinez2021-03-04 23:47:25 -0600
commit56946f924c10b758b132a6a087703d15a8d3a09a (patch)
treea3df9be6469e79d71f0daa47c77e7f0c9900ae9e
parent6ecd4106155dff0c765b34d4de7436d7c6ba358c (diff)
downloadaur-56946f924c10b758b132a6a087703d15a8d3a09a.tar.gz
small fixes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3adfcc3b519b..445dec0d69c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = vim-fzf-git
pkgdesc = Vim plugin that integrates fzf, the fuzzy file finder
- pkgver = r327.f39c92b
+ pkgver = r429.02a192e
pkgrel = 1
url = https://github.com/junegunn/fzf.vim
arch = any
+ groups = vim-plugins
license = MIT
makedepends = git
- depends = vim
+ depends = vim-plugin-runtime
depends = fzf
+ optdepends = bat: syntax-highlighted preview support
+ optdepends = git-delta: formatting git diff output with certain commands
+ optdepends = perl: Tags and Helptags support
+ optdepends = ripgrep: Rg command support
+ optdepends = the_silver_searcher: Ag command support
source = git+https://github.com/junegunn/fzf.vim
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c36183bbd021..106a818a3d4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,19 @@
-# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
-
+# Maintainer: lmartinez-mirror
+# Contributor: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
pkgname=vim-fzf-git
-pkgver=r327.f39c92b
+pkgver=r429.02a192e
pkgrel=1
pkgdesc='Vim plugin that integrates fzf, the fuzzy file finder'
arch=('any')
license=('MIT')
+groups=('vim-plugins')
url='https://github.com/junegunn/fzf.vim'
-depends=('vim' 'fzf')
+depends=('vim-plugin-runtime' 'fzf')
+optdepends=('bat: syntax-highlighted preview support'
+ 'git-delta: formatting git diff output with certain commands'
+ 'perl: Tags and Helptags support'
+ 'ripgrep: Rg command support'
+ 'the_silver_searcher: Ag command support')
makedepends=('git')
source=('git+https://github.com/junegunn/fzf.vim')
md5sums=('SKIP')
@@ -20,5 +26,6 @@ pkgver() {
package() {
cd fzf.vim
install -Dm644 plugin/fzf.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/fzf/fzf.vim"
- cp -R autoload bin doc "${pkgdir}/usr/share/vim/vimfiles/"
+ find autoload bin doc -type f -exec install -Dm644 '{}' \
+ "$pkgdir/usr/share/vim/vimfiles/{}" \;
}