summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-18 21:20:01 -0500
committerLuis Martinez2021-03-18 21:20:01 -0500
commitb4b24b48fa4e098bca0156c43fc7326ffde932f4 (patch)
treee966c52aa45cabf45bd4ab5111494c9db3cee033
parent56946f924c10b758b132a6a087703d15a8d3a09a (diff)
downloadaur-b4b24b48fa4e098bca0156c43fc7326ffde932f4.tar.gz
fix file permissions; add LICENSE file
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD16
3 files changed, 36 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 445dec0d69c0..8c8883dfdc52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vim-fzf-git
pkgdesc = Vim plugin that integrates fzf, the fuzzy file finder
- pkgver = r429.02a192e
- pkgrel = 1
+ pkgver = r431.1ef72b1
+ pkgrel = 2
url = https://github.com/junegunn/fzf.vim
arch = any
groups = vim-plugins
@@ -15,7 +15,9 @@ pkgbase = vim-fzf-git
optdepends = ripgrep: Rg command support
optdepends = the_silver_searcher: Ag command support
source = git+https://github.com/junegunn/fzf.vim
- md5sums = SKIP
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f
pkgname = vim-fzf-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c28e01df1b6c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2015 Junegunn Choi
+
+MIT License
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 106a818a3d4c..1a776ec56dc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: lmartinez-mirror
# Contributor: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
pkgname=vim-fzf-git
-pkgver=r429.02a192e
-pkgrel=1
+pkgver=r431.1ef72b1
+pkgrel=2
pkgdesc='Vim plugin that integrates fzf, the fuzzy file finder'
arch=('any')
license=('MIT')
@@ -15,8 +15,9 @@ optdepends=('bat: syntax-highlighted preview support'
'ripgrep: Rg command support'
'the_silver_searcher: Ag command support')
makedepends=('git')
-source=('git+https://github.com/junegunn/fzf.vim')
-md5sums=('SKIP')
+source=("git+$url" 'LICENSE')
+sha256sums=('SKIP'
+ '595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f')
pkgver() {
cd fzf.vim
@@ -25,7 +26,8 @@ pkgver() {
package() {
cd fzf.vim
- install -Dm644 plugin/fzf.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/fzf/fzf.vim"
- find autoload bin doc -type f -exec install -Dm644 '{}' \
- "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 plugin/fzf.vim "$pkgdir/usr/share/vim/vimfiles/plugin/fzf/fzf.vim"
+ find bin -type f -exec install -Dm 755 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ find autoload doc -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 444 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}