summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2018-06-30 09:35:03 -0400
committerWilson E. Alvarez2018-06-30 09:35:14 -0400
commit8439b44cd18883182567da357308be002a811ab3 (patch)
tree49f197da4cbf5d10c656505f1aad512326703348
parent5ee885f8929c46232fccd47b17c6d147326da751 (diff)
downloadaur-8439b44cd18883182567da357308be002a811ab3.tar.gz
Properly added the latest changes
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af2afb5bd379..ba38ec0df903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vim-gdscript-git
gitname=vim-gdscript3
-pkgver=r3.3993775
+pkgver=r70.e9e0cce
pkgrel=1
pkgdesc="Vim syntax highliting for the Godot Game Engine scripting language GDScript"
arch=('any')
@@ -28,5 +28,12 @@ package() {
install -Dm644 "ftplugin/gdscript3.vim" "$pkgdir/$vim_share/plugin/gdscript3.vim"
install -Dm644 "indent/gdscript3.vim" "$pkgdir/$vim_share/indent/gdscript3.vim"
install -Dm644 "syntax/gdscript3.vim" "$pkgdir/$vim_share/syntax/gdscript3.vim"
+ install -Dm644 "syntax/gdscript3.vim" "$pkgdir/$vim_share/syntax/gdscript3.vim"
+
+ # Recreate all the directories under the python subdirectory in our filesystem:
+ find python -type d -print -exec install -dm755 "$pkgdir/$vim_share/"{} \;
+
+ # Now copy all the files with the right permissions:
+ find python -type f -print -exec install -Dm644 {} "$pkgdir/$vim_share/"{} \;
}