summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneworld2018-09-22 18:56:46 +0300
committerneworld2018-09-22 18:56:46 +0300
commite616564a63614c4f2619125e2440f0eddef9ee41 (patch)
treefeef5e24d49ab0a5e6c9be538ead329677f5a084
downloadaur-vim-git-hunk-editor.tar.gz
First version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f77f26f528
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-git-hunk-editor
+ pkgdesc = Very small plugin to easily edit hunk patch by toggling lines
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/neworld/vim-git-hunk-editor
+ arch = any
+ license = MIT
+ depends = vim
+ source = vim-git-hunk-editor-1.0.tar.gz::https://github.com/neworld/vim-git-hunk-editor/archive/v1.0.tar.gz
+ sha256sums = 143288c3728bd7da9f305c8d30e0041d4405b8ffe98dbba6e9773337344ba1e5
+
+pkgname = vim-git-hunk-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdb15b9ebf02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Andrius Semionovas < aneworld at gmail dot com >
+
+pkgname="vim-git-hunk-editor"
+pkgver="1.0"
+pkgrel="1"
+pkgdesc="Very small plugin to easily edit hunk patch by toggling lines"
+arch=("any")
+url="https://github.com/neworld/vim-git-hunk-editor"
+license=("MIT")
+depends=("vim")
+source=("vim-git-hunk-editor-${pkgver}.tar.gz::https://github.com/neworld/vim-git-hunk-editor/archive/v${pkgver}.tar.gz")
+sha256sums=("143288c3728bd7da9f305c8d30e0041d4405b8ffe98dbba6e9773337344ba1e5")
+
+package() {
+ cd "${srcdir}/vim-git-hunk-editor-${pkgver}"
+ install -Dm0644 plugin/git-hunk-editor.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/git-hunk-editor.vim"
+}