summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-02-18 12:18:59 -0600
committerLuis Martinez2021-02-18 12:18:59 -0600
commitd3ff376626056c8a293b617697182f4c662e7738 (patch)
tree6fcb018ff4ae94f5d6b120ca7fa6d493572858f7
downloadaur-d3ff376626056c8a293b617697182f4c662e7738.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD31
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dd18ef28ee0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-gitignore-git
+ pkgdesc = gitignore syntax and plugin for vim
+ pkgver = r165.48416f0
+ pkgrel = 2
+ url = https://github.com/shaggyrogers/vim-gitignore
+ arch = any
+ groups = vim-plugins
+ license = Apache
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-gitignore
+ source = git+https://github.com/shaggyrogers/vim-gitignore
+ source = LICENSE
+ sha512sums = SKIP
+ sha512sums = b99e9d9d73b3dae775a25fa94625da3f60a013a29926bf3a23285642cbd49e14f06a54d683a84046031c0e7e930a269e8329741d3f4d1772f64c0de685ea4179
+
+pkgname = vim-gitignore-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..53d8bad517d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Whitelist
+!PKGBUILD
+!LICENSE
+!.SRCINFO
+!.gitignore
+
+# Blacklist
+*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4dba1a7e962f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+Copyright 2015 gisphm phmfk@hotmail.com
+
+Licensed under the Apache License, Version 2.0 (the "License"); you may not use
+this file except in compliance with the License. You may obtain a copy of the
+License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software distributed
+under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR
+CONDITIONS OF ANY KIND, either express or implied. See the License for the
+specific language governing permissions and limitations under the License.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20cda797f2c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: lmartinez-mirror
+pkgname=vim-gitignore-git
+_pkgname=${pkgname%-git}
+pkgver=r165.48416f0
+pkgrel=2
+pkgdesc="gitignore syntax and plugin for vim"
+arch=('any')
+url="https://github.com/shaggyrogers/vim-gitignore"
+license=('Apache')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("$_pkgname")
+source=("git+$url"
+ "LICENSE")
+sha512sums=(
+ 'SKIP'
+ 'b99e9d9d73b3dae775a25fa94625da3f60a013a29926bf3a23285642cbd49e14f06a54d683a84046031c0e7e930a269e8329741d3f4d1772f64c0de685ea4179')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ find ftdetect ftplugin indent neosnippets pythonx snippets syntax UltiSnips \
+ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+