summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2016-02-18 22:24:45 +0000
committerEric Engestrom2016-02-18 22:27:21 +0000
commit7facc92ac870745cda1de0addc4fc60b63e13362 (patch)
treecbe58bcefe1edfd611e43a4742168397142e981a
downloadaur-vim-glsl.tar.gz
initial commit - v1.10.00
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
3 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a08c6c18c24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = vim-glsl
+ pkgdesc = Vim syntax highlighting for the OpenGL Shading Language (GLSL)
+ pkgver = 1.10.00
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=1002
+ arch = any
+ source = glsl.vim::http://www.vim.org/scripts/download_script.php?src_id=3194
+ sha1sums = 37a3284e31d1012e7fdcdc97b37dca4037137693
+
+pkgname = vim-glsl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad0c081bae80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.*
+*.vim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7833f8f43ffa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=vim-glsl
+pkgver=1.10.00
+pkgrel=1
+pkgdesc='Vim syntax highlighting for the OpenGL Shading Language (GLSL)'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=1002'
+_file='glsl.vim'
+source=("${_file}::http://www.vim.org/scripts/download_script.php?src_id=3194")
+sha1sums=('37a3284e31d1012e7fdcdc97b37dca4037137693')
+
+package() {
+ install -Dm644 "${srcdir}/${_file}" "${pkgdir}"/usr/share/vim/vimfiles/syntax/"${_file}"
+}