summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam S Levy2018-07-25 17:26:57 -0800
committerAdam S Levy2018-07-25 17:26:57 -0800
commit12906154b18acd86f08c38077a6c1907bfc8a616 (patch)
treebb602a935404d54b656f147fa88a52a1e5c7b29f
parentd0747838d0235ed976cb05af56fe7c0dacbbb350 (diff)
downloadaur-12906154b18acd86f08c38077a6c1907bfc8a616.tar.gz
upgpkg: vim-go 1.18-1
upstream release - Add custom LICENSE file - Add dependency 'go'
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 530f8d0e7905..26df815dc80b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = vim-go
pkgdesc = Go development plugin for Vim
- pkgver = 1.17
+ pkgver = 1.18
pkgrel = 1
url = https://github.com/fatih/vim-go
arch = any
groups = vim-plugins
license = BSD
depends = vim
+ depends = go
optdepends = go-tools: developer tools
optdepends = gocode-daemon: autocompletion support
options = !strip
- source = https://github.com/fatih/vim-go/archive/v1.17.tar.gz
- sha256sums = dd70a6542c6679048930671f39c57e4e090eb4058045e5f1f05f55164200a8df
+ source = https://github.com/fatih/vim-go/archive/v1.18.tar.gz
+ sha256sums = aa4360b3915ad0001bef969cb690aa4586dbb4ccb5e05035c993690de93828cb
pkgname = vim-go
diff --git a/PKGBUILD b/PKGBUILD
index 1bf44f0328d5..d0718a4ebcc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: yesuu zhang <yesuu79@qq.com>
# Contributor: Tomasz Żok <tomasz.zok [at] gmail.com>
pkgname=vim-go
-pkgver=1.17
+pkgver=1.18
pkgrel=1
pkgdesc="Go development plugin for Vim"
arch=(any)
@@ -10,19 +10,21 @@ url=https://github.com/fatih/vim-go
license=('BSD')
groups=('vim-plugins')
options=('!strip')
-depends=(vim)
+depends=(vim go)
optdepends=(
'go-tools: developer tools'
'gocode-daemon: autocompletion support'
)
source=("https://github.com/fatih/vim-go/archive/v${pkgver}.tar.gz")
-sha256sums=('dd70a6542c6679048930671f39c57e4e090eb4058045e5f1f05f55164200a8df')
+sha256sums=('aa4360b3915ad0001bef969cb690aa4586dbb4ccb5e05035c993690de93828cb')
package() {
cd "${srcdir}/vim-go-${pkgver}/"
local vimdir="$pkgdir/usr/share/vim/vimfiles"
install --directory "$vimdir"
- for dir in assets/ autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/ templates/; do
+ for dir in assets/ autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ rplugin/ scripts/ syntax/ templates/; do
cp --recursive "${dir}" "$vimdir/"
done
+
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}