summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2017-04-02 16:34:52 +0800
committeryesuu2017-04-02 16:34:52 +0800
commitc2b02b514e883617525503490e1f802cc647cbf4 (patch)
tree3043cf3b2d4c3bb97e7fd16f810b8c4526dd1e2b
parente108a92fa9c0ecba96b90b2af7c6d5dc491b596f (diff)
downloadaur-c2b02b514e883617525503490e1f802cc647cbf4.tar.gz
update to v1.12, add group vim-plugins
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 096a5dcc8461..756dbecdc349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Dec 22 11:38:59 UTC 2016
pkgbase = vim-go
pkgdesc = Go development plugin for Vim
- pkgver = 1.10
+ pkgver = 1.12
pkgrel = 1
url = https://github.com/fatih/vim-go
arch = any
+ groups = vim-plugins
license = BSD
depends = vim
optdepends = go-tools: developer tools
optdepends = gocode-daemon: autocompletion support
- source = https://github.com/fatih/vim-go/archive/v1.10.tar.gz
- md5sums = c4eaaedd8f2719428a97ace385697efe
+ source = https://github.com/fatih/vim-go/archive/v1.12.tar.gz
+ sha256sums = f2a2c20ae84accbe5a89d210dd4e86c732af5a859f21226a92ffb32c01f4071d
pkgname = vim-go
diff --git a/PKGBUILD b/PKGBUILD
index 994315320374..43cdc622eddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
# Contributor: Tomasz Żok <tomasz.zok [at] gmail.com>
pkgname=vim-go
-pkgver=1.10
+pkgver=1.12
pkgrel=1
pkgdesc="Go development plugin for Vim"
arch=(any)
url=https://github.com/fatih/vim-go
license=('BSD')
+groups=('vim-plugins')
depends=(vim)
optdepends=(
'go-tools: developer tools'
'gocode-daemon: autocompletion support'
)
source=("https://github.com/fatih/vim-go/archive/v${pkgver}.tar.gz")
-md5sums=('c4eaaedd8f2719428a97ace385697efe')
+sha256sums=('f2a2c20ae84accbe5a89d210dd4e86c732af5a859f21226a92ffb32c01f4071d')
package() {
cd "${srcdir}/vim-go-${pkgver}/"
install --directory "${pkgdir}/usr/share/vim/vimfiles/"
- for dir in assets/ autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/ t/ templates/; do
+ for dir in assets/ autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/ templates/; do
cp --recursive "${dir}" "${pkgdir}/usr/share/vim/vimfiles/"
done
}