summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2015-06-12 00:27:13 +0800
committeryesuu2015-06-12 00:27:13 +0800
commitd3235b9414ff8db25af3b434cecb678a9a056881 (patch)
tree6d44e2aa4515bd8a77072882b9fcc9270a40b0f0
downloadaur-d3235b9414ff8db25af3b434cecb678a9a056881.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e39492041cab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-go
+ pkgdesc = Go development plugin for Vim
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/fatih/vim-go
+ arch = any
+ license = unknown
+ depends = vim
+ optdepends = gocode-daemon: autocompletion support
+ source = https://github.com/fatih/vim-go/archive/v1.0.5.tar.gz
+ md5sums = d32a7d0b7873bb3b291567af24fff563
+
+pkgname = vim-go
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afe1e7f084c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Contributor: Tomasz Żok <tomasz.zok [at] gmail.com>
+
+pkgname=vim-go
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Go development plugin for Vim"
+arch=(any)
+url=https://github.com/fatih/vim-go
+license=(unknown)
+depends=(vim)
+optdepends=('gocode-daemon: autocompletion support')
+source=(https://github.com/fatih/vim-go/archive/v${pkgver}.tar.gz)
+md5sums=('d32a7d0b7873bb3b291567af24fff563')
+
+package() {
+ cd "${srcdir}/vim-go-${pkgver}/"
+ install --directory "${pkgdir}/usr/share/vim/vimfiles/"
+ for dir in autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/; do
+ cp --recursive "${dir}" "${pkgdir}/usr/share/vim/vimfiles/"
+ done
+}