summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2016-12-22 19:40:06 +0800
committeryesuu2016-12-22 19:40:06 +0800
commite108a92fa9c0ecba96b90b2af7c6d5dc491b596f (patch)
tree441d99ca2cc21677dfc726694a2454fbee3381b3
parent5da43a93c5c6e225608fcad6fc946df32f089de0 (diff)
downloadaur-e108a92fa9c0ecba96b90b2af7c6d5dc491b596f.tar.gz
update 1.10
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75f4bb170640..096a5dcc8461 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
# Generated by mksrcinfo v8
-# Wed May 11 22:32:36 UTC 2016
+# Thu Dec 22 11:38:59 UTC 2016
pkgbase = vim-go
pkgdesc = Go development plugin for Vim
- pkgver = 1.6
+ pkgver = 1.10
pkgrel = 1
url = https://github.com/fatih/vim-go
arch = any
license = BSD
depends = vim
+ optdepends = go-tools: developer tools
optdepends = gocode-daemon: autocompletion support
- source = https://github.com/fatih/vim-go/archive/v1.6.tar.gz
- md5sums = 847d3e3577982a9515ad0aec6d5111b2
+ source = https://github.com/fatih/vim-go/archive/v1.10.tar.gz
+ md5sums = c4eaaedd8f2719428a97ace385697efe
pkgname = vim-go
diff --git a/PKGBUILD b/PKGBUILD
index 5b2a202f5815..994315320374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,24 @@
# Contributor: Tomasz Żok <tomasz.zok [at] gmail.com>
pkgname=vim-go
-pkgver=1.6
+pkgver=1.10
pkgrel=1
pkgdesc="Go development plugin for Vim"
arch=(any)
url=https://github.com/fatih/vim-go
license=('BSD')
depends=(vim)
-optdepends=('gocode-daemon: autocompletion support')
+optdepends=(
+ 'go-tools: developer tools'
+ 'gocode-daemon: autocompletion support'
+)
source=("https://github.com/fatih/vim-go/archive/v${pkgver}.tar.gz")
-md5sums=('847d3e3577982a9515ad0aec6d5111b2')
+md5sums=('c4eaaedd8f2719428a97ace385697efe')
package() {
cd "${srcdir}/vim-go-${pkgver}/"
install --directory "${pkgdir}/usr/share/vim/vimfiles/"
- for dir in autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/; do
+ for dir in assets/ autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/ t/ templates/; do
cp --recursive "${dir}" "${pkgdir}/usr/share/vim/vimfiles/"
done
}