summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2015-07-11 00:17:19 +0800
committeryesuu2015-07-11 00:17:19 +0800
commit098753874f4604ac2a4b11f2a320d0db97364c2b (patch)
tree205b25d985f91619564c75973c938cf218ead747
downloadaur-vim-go-git.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f47bbeabdbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-go-git
+ pkgdesc = Go development plugin for Vim
+ pkgver = 20150710
+ pkgrel = 1
+ url = https://github.com/fatih/vim-go
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = go
+ depends = vim
+ conflicts = vim-go
+ conflicts = vim-gocode
+ conflicts = gocode-git
+ source = git+https://github.com/fatih/vim-go.git
+ md5sums = SKIP
+
+pkgname = vim-go-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..732269be93d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Contributor: exul <exul [at] v-net [dot] ch>
+
+pkgname=vim-go-git
+pkgver=20150710
+pkgrel=1
+pkgdesc='Go development plugin for Vim'
+arch=('any')
+url='https://github.com/fatih/vim-go'
+license=(unknown)
+conflicts=('vim-go' 'vim-gocode' 'gocode-git')
+depends=('go' 'vim')
+makedepends=('git')
+source=('git+https://github.com/fatih/vim-go.git')
+md5sums=(SKIP)
+
+package() {
+ cd "${srcdir}/vim-go/"
+ install --directory "${pkgdir}/usr/share/vim/vimfiles/"
+ for dir in autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/; do
+ cp --recursive "${dir}" "${pkgdir}/usr/share/vim/vimfiles/"
+ done
+}