summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Gautier2022-02-02 16:43:04 +0100
committerMax Gautier2022-02-02 16:48:55 +0100
commiteeefa6c606d8b3a81e1460aadaa5017b52bb838c (patch)
tree0f625532a0b6362fb21760399ede9817395502f2
downloadaur-eeefa6c606d8b3a81e1460aadaa5017b52bb838c.tar.gz
Initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2443037adec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-graphql
+ pkgdesc = Vim syntax, file detection, and indentation plugin for GraphQL queries
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/jparise/vim-graphql
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim
+ source = https://github.com/jparise/vim-graphql/archive/v1.4.tar.gz
+ sha512sums = 784212b9e8e6c85d491cfd5850bde9e9bfa720fc087336801080406ce63b6806d28eb39c8f42e8da46aa0011a27d201355c7da27f23985948f6caa40f8f4eb2b
+
+pkgname = vim-graphql
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ef6e7bd8839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Max Gautier <mg+archlinux@max.gautier.name>
+
+pkgname=vim-graphql
+pkgver=1.4
+pkgrel=1
+pkgdesc="Vim syntax, file detection, and indentation plugin for GraphQL queries"
+arch=('any')
+url="https://github.com/jparise/$pkgname"
+license=('MIT')
+depends=('vim')
+groups=('vim-plugins')
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('784212b9e8e6c85d491cfd5850bde9e9bfa720fc087336801080406ce63b6806d28eb39c8f42e8da46aa0011a27d201355c7da27f23985948f6caa40f8f4eb2b')
+
+package() {
+
+ cd "$pkgname-$pkgver"
+ install -dm 644 "license" "$pkgdir/usr/share/licenses/${pkgname}/license"
+
+ # install vimfiles
+
+ local vimfiles="$pkgdir/usr/share/vim/vimfiles"
+ mkdir -p "$vimfiles"
+ cp -dr --no-preserve=ownership \
+ after \
+ autoload \
+ doc \
+ ftdetect \
+ ftplugin \
+ indent \
+ syntax \
+ "$vimfiles"
+}