summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlafleur2020-09-13 23:29:27 +0200
committerlafleur2020-09-13 23:29:27 +0200
commitf0ca2b501111cdfa5df6dea6d16fabf7e19c068e (patch)
treec8e63d9c30dc3aa3d94945efe546813493127387
parent1a02ba9c3c7004f5ac31790efc41a9c227e1c990 (diff)
downloadaur-f0ca2b501111cdfa5df6dea6d16fabf7e19c068e.tar.gz
managed srcdir
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7547decc67c5..3cd0d776dad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = vim-gtk-recent
+pkgbase = vim-gtk-recent-git
pkgdesc = logs files opened in vim into GObject recent files
- pkgver = r1
+ pkgver = r3.9311fad
pkgrel = 1
url = https://gitlab.gnome.org/lafleur/vim-gtk-recent
arch = i686
@@ -9,10 +9,10 @@ pkgbase = vim-gtk-recent
license = GPLv3
depends = vim
depends = python-gobject
- provides = vim-gtk-recent-git
- conflicts = vim-gtk-recent-git
- source = https://gitlab.gnome.org/lafleur/vim-gtk-recent.git
+ provides = vim-gtk-recent
+ conflicts = vim-gtk-recent
+ source = vim-gtk-recent::git+https://gitlab.gnome.org/lafleur/vim-gtk-recent
md5sums = SKIP
-pkgname = vim-gtk-recent
+pkgname = vim-gtk-recent-git
diff --git a/PKGBUILD b/PKGBUILD
index 3771d196c167..b5de96f3daf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: la Fleur <lafleur at boum dot org>
-pkgname=vim-gtk-recent
-_pkgname=${pkgname}-git
-pkgver=r1
+pkgname=vim-gtk-recent-git
+_pkgname=${pkgname%-git}
+pkgver=r3.9311fad
pkgrel=1
pkgdesc="logs files opened in vim into GObject recent files"
arch=('i686' 'x86_64')
@@ -13,22 +13,19 @@ provides=(${_pkgname})
conflicts=(${_pkgname})
groups=('vim-plugins')
#source=("$pkgname"::'https://gitlab.gnome.org/lafleur/vim-gtk-recent.git')
-source=('git://gitlab.gnome.org/lafleur/vim-gtk-recent.git')
+source=("${_pkgname}::git+https://gitlab.gnome.org/lafleur/${_pkgname}")
md5sums=('SKIP')
-#pkgver() {
-# cd "$srcdir/$pkgname"
-# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-#}
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
local _installpath="${pkgdir}/usr/share/vim/vimfiles"
install -d "${_installpath}/plugin"
- cd "$srcdir"
+ cd "${srcdir}/${_pkgname}"
install -D -m644 "gtk-recent.vim" "${_installpath}/plugin/"
-
- #cd "$pkgname"
- #cp -r -t "${_installpath}" indent syntax syntax_checkers UltiSnips
}