summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Sharpe2019-04-07 20:16:54 -0700
committerJeff Sharpe2019-04-07 20:16:54 -0700
commit58a3dc6c7d7dc1beb8f226d45b7db61eea673476 (patch)
treeea35948aba58e766d88625c7c6c72760c04dbbc4
downloadaur-58a3dc6c7d7dc1beb8f226d45b7db61eea673476.tar.gz
Initial init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db896d62f1f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-gutentags-git
+ pkgdesc = A Vim plugin that manages your tag files
+ pkgver = r244.4814b67
+ pkgrel = 1
+ url = https://bolt80.com/gutentags/
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-runtime
+ source = git+https://github.com/ludovicchabant/vim-gutentags.git
+ md5sums = SKIP
+
+pkgname = vim-gutentags-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..26e6378cddf7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.vim
+*.pkg.tar.xz
+tags
+vim-gutentags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25e6230f6ac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: olddog <jeff@impcode.com>
+
+pkgname=vim-gutentags-git
+pkgver=r244.4814b67
+pkgrel=1
+pkgdesc='A Vim plugin that manages your tag files'
+arch=('any')
+url='https://bolt80.com/gutentags/'
+license=('MIT')
+makedepends=('git')
+groups=('vim-plugins')
+depends=('vim-runtime')
+source=("git+https://github.com/ludovicchabant/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p "${_installpath}"
+ cp -r autoload doc plugin res plat "${_installpath}"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}